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Revision History 

Date Section title Description of changes 
May 2021 1 Create an export 

destination 
Added note pointing to Connexion client version 3.0 
documentation. 

May 2014 3 Import bibliographic records Removed information on the expiration of save files. 
April 2013 All Removed references to Heritage Printed Books. 
September 2011 2 Export bibliographic records • You can export records in MARC XML format in

addition to the other format choices.
• If you set an option in Tools > Options > Export,

you can export workforms.
3 Import bibliographic records You can also import records in MARC XML format in 

addition to the other format choices. 
January 2008 2 Export bibliographic records • More Dublin Core record standards are available

for exporting records (besides MARC 21, which is
the default for export):

o Dublin Core Qualified
o Dublin Core Simplified
o OCLC Dublin Core Qualified
o OCLC Dublin Core Simplified

All Dublin Core standards are structured in
XML

• Added more details about Dublin Core
conversions.

• New option to get a warning message before the
client exports records containing parallel but
unlinked non-Latin script fields.

3 Import bibliographic records • Two more Dublin Core record standards are
available for importing records (besides MARC 21,
which is the default).

• Added Dublin Core file formats at legitimate types
of files from which to import records.

4 Retrieve local system 
records using a Z39.50 
connection 

You can now define a use attribute (formerly, only the local 
record use attribute was available), and you can define 
other structure, truncation, or relations attributes, if needed, 
for record searching. 

© 2014 OCLC 

The following OCLC product, service and business names are trademarks or service marks of OCLC, Inc.: Connexion, OCLC, 
WorldCat, and "The world's libraries. Connected." 

In addition, the WorldCat symbol and OCLC symbol are service marks of OCLC. Third-party product and service names are trade- 
marks or service marks of their respective owners. 

OCLC grants permission to photocopy this publication as needed. 



Page 3 of 31  

Table of Contents 
1 Create an export destination 

Create an export destination, 4 
Types of export destinations and settings, 5 
Change settings for an export destination, 6 
Delete an export destination, 6 

2 Export bibliographic records 
Records you can export, 7 
About exporting records online or offline, 7 
Export records immediately, 9 
Batch export records, 10 
Select a record standard and character set for exported bibliographic records, 10 
Define fields to delete from exported records, 13 
Optional. Display a temporary report after immediate export, 13 
Optional. Display a warning before exporting bibliographic records that include 

unlinked non-Latin script fields, 14 
Optional. Enable export of workforms, 15 

3 Import bibliographic records 
Why import bibliographic records?, 16 
Records you can import, 16 
Restrictions on taking actions on imported OCLC bibliographic records, 16 
About import files, 17 
Import records, 18 
Results of importing records, 19 
Import conversion details, 21 
Select a record standard and character set for imported bibliographic records, 21 
Apply default constant data or assign a free-text My Status to imported records, 24 
Find imported bibliographic records, 25 
Download records from an OCLC service, 26 
Process unresolved batchload records, 27 

4 Retrieve local system records using a Z39.50 connection 
About retrieving local system records, 28 
Set up a connection to a host local system, 28 
Connect to a local system host and retrieve a record, 30 



Cataloging: Export or Import Bibliographic Records 

Page 4 of 31 

1 Create an export destination 

Note: If you are using Connexion client version 3.0 or newer, see Connexion client for applicable documentation. 

Create an export 
destination 

Requirement: You must create at least one export destination in order to export 
records. 

You can export records from Connexion client to: 

 A file on your workstation (use the same file for all exports or specify a file name
when exporting)

 A communications or print (LPT) port

 A communications connection (asynchronous or TCP/IP)

 An OCLC Gateway connection to a local system

To create a destination: 

Action 

1 On the Tools menu, click Options or press <Alt><T><O>, and then click the Export 
tab. 

2 In the Select an Export Destination list, click Create. 

3 In the New Export Destination window, select one of the following export destination 
types, and click OK. 
 File
 LPT Port
 Connection
 OCLC Gateway Export

4 In the window appropriate for the destination type, select settings and options, and 
click OK. 

See the list below of destination types and their settings and options for more 
details. 

5 In the Export Destination Name window, the client provides a suggested name for 
the destination that reflects its type and settings or location. 

Click OK to accept the default name, or enter a new name, and then click OK. 

Result: The name appears in the Select an export destination list. 

6 When finished, click Close to apply the settings and close the Options window. 
Or 
Click Apply to apply the settings without closing the window. 

https://help.oclc.org/Metadata_Services/Connexion/Connexion_client
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Types of export 
destinations and 
settings 

When you click Create in the Options Export tab, you select the destination type 
and then enter settings appropriate to the type you selected, as shown in the 
following table: 

 
If you select this 
export destination 
type... 

 
 
In this window, enter these settings... 

File In the Export Filename window: 
 
Select a file or type a file name (for example, export.dat) 
in the File Name box. 

 
Note: By default the destination name contains the path 
name X:\Program Files\OCLC\Connexion\Program\, 
where X is the letter of your hard drive. You are not required 
to have the path name as part of the file name. 

LPT Port In the Export LPT Settings window: 
 
Select the LPT (parallel) port and type of translation you 
want to use. 

Connection 
(Serial, network, or 
TCP/IP 
communications 
connection) 

1. In the Export Connection Settings window: 
 

Select the type of translation your local system requires, 
and click Create. 

 2. In the New Communication Connection window: 

 Select Asynchronous or TCP/IP. 

 — In the Ashnchronous Settings window, accept default 
or change settings for port, baud rate, parity, data bits, 
stop bits, and flow control. 

— In the TCP/IP Settings window, enter the name of the 
host system to which you export. Change other 
options if needed. 

Trouble spot. When you create a TCP/IP Connection for 
the first time, you may not be able to complete the process. 
After you enter your TCP/IP settings and click OK, the client 
adds the destination name to the list in the Export 
Connection Settings window. If the OK button is unavailable 
(grayed out), to complete adding your destination: 
1. Double-click the name of your destination in the Export 

Connection Settings window. 

 The Export Destination Name window opens showing 
your destination name prefixed by Connection: 

 2. Click OK. 

 The client adds the destination to the list in the Options 
Export tab 
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If you select this 
export destination 
type... 

 
 
In this window, enter these settings... 

OCLC Gateway 
Export 

In the OCLC Gateway Export - Local System Settings 
window: 

 
Enter or select the settings required for your local system: 

 
 Enter host name and port 
 Select local options for exporting 
 Enter timeout (minutes), number of retries, and delay 

(minutes) 
 Select the type of local system authorization: 

 
Local system logon (logon ID and password) 
And/or 
User ID 

 

 
 

Change settings for an 
export destination 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Delete an export 
destination 

See the Setup Worksheet for OCLC Connexion Client for more details on settings. 
 

If you want to export to a different file or change the host name or port name for a 
TCP/IP connection, for example: 

 
 Action 

1 In the Export tab (Tools > Options), select the name of an export destination, and 
click Edit. 

2 In the Settings window appropriate to the destination type, edit the settings and click 
OK. 

3 In the Export Destination Name window, keep or edit the displayed name, and click 
OK. 

4 In the Export tab, click Close, or press <Enter> to apply the settings and close the 
Options window. 
Or 
Click Apply to apply the settings without closing the window. 

 Action 

1 In the Export tab (Tools > Options), select the name of an export destination, and 
click Delete. 

2 Click Close, or press <Enter> to apply the settings and close the Options window. 
Or 
Click Apply to apply the settings without closing the window. 
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2 Export bibliographic records 
 

Records you can 
export 

 
 
 
 
 
 
 
 
 
 

About exporting 
records online or 
offline 

 Records retrieved from WorldCat, from the online bibliographic save file, or from 
the local bibliographic save file 

 Workforms (new records you create) from the online or local bibliographic save 
file. (You must set an option in Tools > Options > Export to be able to export 
workforms. See details below.) 

 Bibliographic and authority records in the same file. 

 Records containing non-Latin scripts. 
 

No minimum authorization level is required to export records. 
 

 Immediate export while logged on or offline. 
— Export occurs immediately whether you are logged on or offline unless you set 

an option in Tools > Options > Batch to perform bibliographic or authority 
record export in batch. 

— If you export immediately while offline, the client tracks your information and 
sends it to the system the next time you log on. When data is sent, the system 
displays a message summarizing the export information sent. 

— If you export records from the local file while logged on and change the default 
local file from either the local file manager (File > Local File Manager) or from 
the Search Bibliographic Local Save File window (Cataloging > Search > 
Local Save File), the client sends any export billing information to the system 
and displays a message summarizing the export information sent. 

 Batch export. Mark records for batch export in the local save file. You must set 
an option in Tools > Options > Batch; otherwise, local file records export 
immediately. 

 Choose record standard, character set. Select MARC 21, one of four Dublin 
Core record standards, or MARC XML; select MARC-8 or UTF-8 Unicode 
character set: 
— Export bibliographic records using the MARC 21 record standard (default) or 

select: 
- Dublin Core Qualified 
- Dublin Core Simple 
- OCLC Dublin Core Qualified 
- OCLC Dublin Core Simple 
- MARC XML 

— Export bibliographic and authority records using the MARC-8 character set 
(default) or the UTF-8 Unicode character set (required for Dublin Core export). 

 
 Non-Latin script data in bibliographic records. Export bibliographic records 

containing non-Latin scripts: 
— All Connexion client users can view, enter, and edit non-Latin script data in 

records. By default, the exported records retain both Latin and non-Latin script 
fields, when present, with the Latin script data in tagged fields and the non- 
Latin data in corresponding MARC format 880 fields. 
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— You can change this option if you do not want to retain the non-Latin script 
data. Under Tools > Options > International change to exporting the Latin 
data only. 

— If you do want to retain non-Latin script data, you can also change to exporting 
the non-Latin data only or both types of data, with the non-Latin data in the 
tagged fields. 

 
Caution: If you export records containing non-Latin script fields that are 
parallel to Latin script fields but are not linked, depending on your local system 
characteristics, the non-Latin script data may not show after export. 

 
If you have this problem, select the Warn before exporting bibliographic 
records that include unlinked non-Latin script fields check box in Tools > 
Options > Export to receive a warning message when records you try to 
export have unlinked fields. The option applies to records you export singly or 
from a list, online or offline, or via batch processing. 

 
See more details in the Export tab (Options window) description. 

 Validation. Validate exported records: 
 

By default, the system does no validation when you export records, but you can 
set an option to perform basic or full validation or re-set to none (Tools > 
Options > General / Validation Level Options). 

 Generated OCLC number. OCLC number automatically generated in 035 field: 
 

With the expansion of the OCLC number from 8 digits to 9 digits to accommodate 
WorldCat record 100,000,000 and beyond, exported records contain an 
automatically generated 035 field containing the OCLC number, whether the 
number is 8 or 9 digits. The OCLC number is also retained in field 001. 

 
Note: Generating the OCLC number in the 035 field helps to accommodate 
various technical issues in libraries, facilitate deep-linking for WorldCat.org, and 
support better local control of bibliographic records. The 035 field is repeatable. 

 Generated ISBN expansion. 
 

As a result of expanding the ISBN to the new 13-digit format, when you take a 
final action on a record that contains an ISBN in only one format, 10-digit or 13- 
digit, Connexion automatically generates the other format. ISBNs are stored in 
field 020. 

 
To have the 10- or 13-digit number, whichever is not in the record, generated 
automatically for exported records, you must take a final action before you export; 
otherwise, the export retains only ISBN(s) already in the record. 

 
See Technical Bulletin 253: ISBN and OCLC Number Changes for more detail: http:/ 
/www.oclc.org/support/documentation/worldcat/tb/253/. 

http://www.oclc.org/support/documentation/worldcat/tb/253/
http://www.oclc.org/support/documentation/worldcat/tb/253/
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Export records 
immediately 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Action 

1 Logged on or offline, display the record you want to export. 
Or 
Select records in a list:: 

 
To select adjacent records, click to highlight the first entry, and then press and hold 
<Shift> and click the last entry. Or to select nonadjacent entries, click to highlight the 
first entry, and then press <Ctrl> and click to highlight each additional entry. 

 
Notes: 
 To export immediately while offline, check that the option to export in batch is 

cleared in Tools > Options > Batch. 
 If you are offline and export in one of four available Dublin Core record standards, 

the client automatically logs you on to access the metadata crosswalk program 
that converts records from one record standard to another. 

 
For automatic logon, you must have either: 
— A general default authorization and password defined in Tools > Options > 

Authorizations 
Or 

— A default authorization and password defined for the local file in File > Local 
File Manager / Authorization 

 
If you don't have a default authorization, the client prompts you to enter an 
authorization and password. 

2  
On the Action menu, click Export, or click , or press <F5>. 

3 Continue exporting more records if needed. 
Results: 
 The client exports the record immediately to the destination you created and 

selected. 
Or 
If you export to a file and you selected the option File:(Prompt for filename), 
after your first export per session, the client prompts you to locate or enter the file, 
and then exports the record. 

 The record's Export status changes to C (completed) or F (failed) in the record's 
status bar and in the Export column of the list if exporting selected records from a 
list. 

 If you set an option (see procedure above), the client opens a temporary Export 
Results report. 

Caution about exporting to a file that already exists: 
 The first time during a logon session that you export record(s), the client asks if 

you want to overwrite, append, or cancel the export and use another file. 
 For the remainder of your current logon session and until you close the client 

and reopen it, any time you export, the client automatically appends records to 
any records already in the export file (on the assumption that you are building a 
file of exported records). 

 You must close and reopen the client before exporting if you want to overwrite 
records in the file or change to another file. 

 See also the Caution below about not appending records exported singly in 
Dublin Core to an existing file. 
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Batch export records First, select an option for batch processing. Records export immediately 
whether you are logged on or offline. You must set an option to mark records for 
batch export: 

 
 Action 

1 On the Tools menu, click Options, or press <Alt><T><O>, and then click the Batch 
tab. 

2 In the Record Actions area under Perform local actions in batch, select the 
Bibliographic Record Export and/or the Authority Record Export check box. 

3 Click OK, or press <Enter>. 
Result: The client keeps your setting each time you open the program unless you 
change it. 

4 Optional. To return to exporting immediately rather than in batch mode, clear the 
settings in Tools > Options > Batch tab. 

Then mark records for batch export. Once the option is set, to mark records for 
batch export: 

 
 Action 

1 Display a bibliographic record from the local save file that you want to export. 
Or 
Select records in a local bibliographic save file list: 

 
To select adjacent records, click to highlight the first entry, and then press and hold 
<Shift> and click the last entry. Or to select nonadjacent entries, click to highlight the 
first entry, and then press <Ctrl> and click to highlight each additional entry. 

2 
On the Action menu, click Export, or click , or press <F5>. 
Results: 
 The record(s) are marked for export in batch mode. 
 The export status in the record's status bar or in the Export column of the 

authority local file list changes to R (Ready). 
Note: You can remove a record from the batch before processing. See Cataloging, 
Take Actions on Bibliographic Records, "Take actions on bibliographic records." 

3 When ready, run batch processing. (See Cataloging, Take Actions on Bibliographic 
Records, “Run batch processing.") 

 

Select a record 
standard and 
character set for 
exported bibliographic 
records 

 Record standard. Select the MARC 21 record standard (default), one of four 
Dublin Core record standards, or MARC XML(see a list in the procedure below). 

Caution: If you export single records in Dublin Core or MARC XML to an existing 
file, do not append records to the file. Client Dublin Core and MARC XML export 
files must have prologue and container code at the beginning and end of the file. 
An existing client export file already has the prologue and container. When you 
append one record at a time, a prologue and container are added at the 
beginning and end of each record. 
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 Character set. Select the UTF-8 Unicode character set or the MARC-8 character 
set (default). (See more about MARC-8 character sets at http://www.loc.gov/ 
marc/specifications/speccharmarc8.html. See more about UTF-8 Unicode at 
http://www.loc.gov/marc/specifications/speccharucs.html.) 

Note: OCLC tested exporting using UTF-8 Unicode with local system vendors 
and lists vendors on the Connexion Web site whose systems tested successfully. 
See vendor list at < http://www.oclc.org/connexion/about/features/export/ 
default.htm >. 

 These settings apply to records you export singly or from a list, online or offline, 
or via batch processing. 

 
To select a record standard and character set for exporting bibliographic records: 

 
 Action 

1 Click Tools > Options > Export (or press <Alt><T><O>). 

2 Click Record Characteristics. 

3 Under Bibliographic Records, click one of the following buttons: 
 Select one of the following from the Record Standard list: 

— MARC 21 (default) 
— Dublin Core Qualified 
— Dublin Core Simple 
— OCLC Dublin Core Qualified 
— OCLC Dublin Core Simple 
— MARC XML 

Notes: 
- When you select Dublin Core or MARC XML, the character set 

always defaults to UTF-8 Unicode. 
- All Dublin Core standards are structured in XML. 

 Select one of the following from the Character Set list: 
— MARC-8 (default) 
— UTF-8 Unicode 

Note: Follow the same procedure to select a character set for exporting 
authority records. (The only available record format for exported authority 
records is MARC 21.) 

4 Click OK, or press <Enter> to save your setting and close the window, or click 
Cancel to cancel changes. You are returned to the Export page in the Options 
window. 

More about Dublin Core 
 

The Dublin Core Metadata Element Set, called Dublin Core or DC, is an 
international standard that supports creating and sharing simple-to-moderately- 
complex machine-readable descriptions of resources, especially those on the 
Internet. See more about Dublin Core on the Dublin Core Web site at http:// 
www.dublincore.org. 

 
 Dublin Core Simple = 15 primary elements of description. 

http://www.loc.gov/
http://www.loc.gov/marc/specifications/speccharucs.html.)
http://www.oclc.org/connexion/about/features/export/
http://www.dublincore.org/
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 Dublin Core Qualified = A series of refinements, also called qualifiers, that can be 
applied to the primary elements. 

 
Example: Dublin Core Simple includes an element for date. Dublin Core 
Qualified includes a qualifier to describe the kind of date. 

 
 OCLC forms of Dublin Core Simple and Dublin Core Qualified = 11 additional 

elements that can be used with both Dublin Core types to define information 
about the record, not about the resource itself. 

 
Example: OCLC Dublin Core Simple and OCLC Dublin Core Qualified include 
elements for 040 a (recordContentSource) and 040 b (languageOfCataloging). 

 
The following is a list of OCLC elements for defining record information and the 
corresponding field/subfield of the equivalent MARC record: 

 
MARC field/subfield OCLC Dublin Core element name 

040 a recordContentSource 

003 recordControlNumberIdentifier 

008/00-15 (Date entered) recordCreationDate 

010 a recordIdentifier 

010 b recordIdentifier 

001 (OCLC number) recordIdentifier 

040 b languageOfCataloging 

019 a recordOCLCControlNumberCross-Reference 

994 b (OCLC institution 
symbol) 

OCLC-MARCProcessingInformation 

994 a (Transaction code 
(C0)) 

OCLC-MARCProcessingInformation 

040 c recordTranscribingAgency 

Results of character set selection: 
 

MARC-8 export Unicode export 

Uses MARC-8 character set Uses UTF-8 character set 

Leader position 9 is <blank> Leader position 9 has the value a 
Unicode characters that cannot be 
converted to MARC-8 are changed to 
the hex value enclosed in brackets 

All characters are exported, even if not 
included in MARC-8 characters 
approved for MARC-21 cataloging 

If the record contains non-Latin scripts: 
 Field 066 is added automatically, 

indicating the presence of non-Latin 
script 

 Subfield 6 is included but a script 
identifier is not 

If the record contains non-Latin scripts: 
 No field 066 is added 
 A script identifier is included 
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In the Export window (Tools > Options), click the Display Report for Immediate 
Export Results check box. 

 
Default: Check box is cleared. The client does not display a report. 

 
See a detailed description of the report immediately following this procedure. 

 
Caution: 
 If you want to keep data in the Export Results report, you must print or copy and 

paste data into another application before you close the report. The client does 
not save the report. 

 If you export records in MARC 21, have validation options for export set to 
Basic or Full in Tools > Options > Export (default: None), and validation 
errors occur, the list of errors opens behind the temporary report of results. 
Move or close the report window to see the validation errors. 

Action 

 

Define fields to delete 
from exported records 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Optional. Display a 
temporary report after 
immediate export 

Specify fields to delete from exported records separately for bibliographic and 
authority records: 

 
 Action 

1 On the Tools menu, click Options (or press <Alt><T><O>), then click the 
Export tab, and then click Field Export Options. 

2 In the Field Export Options window, in the Bibliographic Records box or the 
Authority Records box, enter tags you want to delete, each separated by a 
comma, or enter a range of tags. 

 
Example: In the Bibliographic Records box, type 920, 938, 945-999 to delete 
fields 920, 938, and 945 through 999 from exported records. 

3 Click OK, or press <Enter> to save your setting and close the window. 
Or 
Click Cancel to cancel changes. 
Or 
Click Apply to save settings without closing the window. 

4 When finished, click OK to close the Options window. 

Set an option to display a temporary report showing results, including any Dublin 
Core mapping errors (if you have the Dublin Core export option selected), when you 
export records immediately: 

 

The temporary report shows: 
 
 The path and file name of the export destination 

 Report start time 

 Record standard and character set selected for bibliographic and authority record 
export (only MARC-21 is available for authority records) 

 Number of bibliographic and authority records successfully exported 
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 Any Dublin Core mapping errors (bibliographic records only) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Optional. Display a 
warning before 
exporting 
bibliographic records 
that include unlinked 
non-Latin script fields 

For each element of a record mapped incorrectly, the report table shows the 
OCLC record number, location, element ID, and mapping error. 
— Location 

- The location indicates which field (v), indicator (i), and subfield (s) did not 
map. 
Example: 245:7/h:5 (h represents h); this error shows that data did not 
map to h 

- No indicators are mapped to Dublin Core. 
- If the entire variable field did not map, all subfields are listed. 
- Ignore other data such as colon (:) followed by a number, ed:, or ex:. 

— Element ID. Ignore data in the element ID. 
— Mapping error. The mapping error indicates whether the mapping failed or 

was incorrect. 
 

Some local systems may not display non-Latin script data in parallel but unlinked 
fields in exported records. If this is a problem in your local system, set an option for 
a warning: 

 

 

In the Export Options window (Tools > Options), click the Warn before 
exporting bibliographic records that include unlinked non-Latin script fields 
check box. 

 
Default: Check box is cleared. The client does not display a warning. 

 
Results when option is selected: 
 If you get the warning when you export a single record, click Yes to continue 

exporting or No to stop. 
 If you get the warning when you export multiple records selected in a list or 

when you mark records in the local file for batch export, click Yes to continue, 
click No to skip the record with unlinked fields and then continue, or click 
Cancel to stop the process. 

Action 
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Optional. Enable 
export of workforms 

This option supports vendor creation of records to be loaded into WorldCat. Since 
some library local systems may not support incoming workforms, the client does not 
export workforms by default; you must set the option. The option applies to all online 
and local save file types (bibliographic and authority). Workforms are new records 
that have not been added to WorldCat and therefore do not have OCLC control 
numbers. 

 

 

In the Export Options window (Tools > Options), click the Allow export of 
workforms check box. When finished setting all Export options, click OK. 

 
Default: Check box is cleared. The Export command is disabled for a displayed 
workform, or you are prevented from exporting any workforms selected in a list. 

 
Results: 
 If the option is selected, the Export command is enabled for a displayed 

workform in an online or local save file, or for selected records in a save file list 
that include workforms. 

 If the option is not selected, the Export command is disabled for a displayed 
workform in an online or local save file. The Export command is enabled for 
selected records in a list that include workforms. However, when you export, 
you get an error message "Action not valid for record [save file number]." You 
must de-select workforms to export. 

Action 
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3 Import bibliographic records 
 

Why import 
bibliographic 
records? 

 
 
 
 
 
 
 
 
 
 
 
 

Records you can 
import 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Restrictions on taking 
actions on imported 
OCLC bibliographic 
records 

 Add bibliographic records created in your library's local system to WorldCat. 

 Process bibliographic records from OCLC services, including: 
— Cataloging Partners 
— Contract Cataloging 
— PromptCat 
— Bibliographic Record Notification 
— GovDoc 
— Batchload 
— WorldCat Collection Sets 

 Process unresolved Batchload records. 
 
 Bibliographic and authority records in the same file. 

 Records in the MARC 21 record standard (default), the Dublin Core Qualified or 
Dublin Core Simple standard, or MARC XML (you select the option). 

 Records using MARC-8 or UTF-8 Unicode character sets (you select the option, 
except that UTF-8 Unicode is required for Dublin Core import). 

 Records exported from your library’s local system. Export the records to a file via 
your system's MARC export function and then import from the file. 

 
Alternative: Retrieve (import) local system records using a Z39.50 connection. 
The client automatically imports a local system record when you retrieve. (See 
section below for details.) 

 Bibliographic records received from OCLC services (see the list in the preceding 
section). 

 OCLC bibliographic records (records that contain an OCLC control number) from 
your local system. 

 Non-OCLC bibliographic records are: 
— Imported as new records (workforms) 
— Actionable (you can take any actions on imported non-OCLC records that you 

take on bibliographic workforms you create, with some restrictions, described 
below) 

 Records containing non-Latin script data. 
 

You can: 
 
 Take most actions on imported OCLC bibliographic records, including: Derive > 

New Record, Export, Update Holdings, and Validate. 
 

You cannot: 
 
 Initially delete holdings. Imported OCLC records do not indicate whether the 

item is Held or Not Held by your library. Therefore, you cannot take the Delete 
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Holdings action on imported record. 

However, when logged on, you can validate imported records to update the 
holdings information and then use the Delete Holdings command. 

To view holdings from the record, use Display Holdings on the View menu. 

 Take a Replace Record action on a record imported to the online save file 
unless you first Lock WorldCat Record (Action menu) online.
Caution:
Locking the WorldCat record loses any edits you made. If you use an 
imported OCLC bibliographic record to lock the corresponding WorldCat 
record, Connexion locks and displays the current version of the WorldCat 
record, overwriting any changes you made to the imported record. The system 
warns you that your changes will be lost and asks whether you want to 
continue. Click No to keep your edited record, or click Yes to overwrite it.

 Use Report Error (Action menu) on an imported bibliographic record.

About import files An import file can contain both bibliographic and authority records. The following 
table gives more details about import files: 

Property Requirements and notes 

File type Import files must be ASCII (plain text) files–for example, with 
file extension *.dat or *.mrc–that contain records in one of 
these standards: OCLC-MARC or MARC 21 or, for 
bibliographic records only, Dublin Core Qualified,Dublin 
Core Simple, or MARC XML. 

Caution: If you try to import from a non-MARC file, or a non- 
Dublin Core file (Qualified or Simple), or MARC XML–for 
example, a file with the extension *.doc, *.xls, *.mdb, *.msg, 
*.gif, *.jpeg, or *.tif)–Connexion displays an error message. 

Record standard 
and character set 

Record standard. Select the MARC 21 (default), Dublin 
Core Qualified, Dublin Core Simple, or MARC XML record 
standard for importing. 

Character set. Select the MARC-8 (default) or UTF-8 
Unicode character set.Go to File > Import Records and 
click Record Characteristics. For Dublin Core record 
standards, only UTF-8 Unicode can be selected. 

Size No prescribed maximum for file size (KB or MB). 

The maximum number of records you can import depends 
on the number of records currently in your bibliographic or 
authority save file. You can import to your online or local 
save file, which can each contain a maximum of 9,999 
records. 

Location Hard disk or network drive connected to local workstation. 
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Import records Bibliographic records you import are placed in the bibliographic save file you specify 
(online or local) with the source status Imported. 

 
 Action 

1 Select and/or set up the location for the file of records you want to import: 
1. Create or retrieve a file of records to import. 

— Export bibliographic and/or authority records from OCLC software or from your 
local system. 
Or 

— Retrieve a file of bibliographic records received from your OCLC cataloging 
service (Cataloging Partners, Contract Cataloging, PromptCat, Bibliographic 
Record Notification, GovDoc, Batchload, or WorldCat Collection Sets). 

2. Move the file of records to your local drive, if needed. 

2 Log on if you plan to import records to the online save file, or if you prefer, the 
client will prompt you to log on when you start the import process (step 7). 

 
If you plan to import to your default local save file, you can import offline. 

 
Notes: 
 Logon for record standard conversion is required. 
 If you are offline and import in one of two available Dublin Core record standards, 

the client automatically logs you on to access the metadata crosswalk program 
that converts records from one record standard to another. 

 For automatic logon, you must have either: 
— A general default authorization and password defined in Tools > Options > 

Authorizations 
Or 

— A default authorization and password defined for the local file in File > Local 
File Manager; click Authorization 

 If you don't have a default authorization, the client prompts you to enter an 
authorization and password. 

3 On the File menu, click Import Records, or press <Alt><F><I>. 

4 In the Import Records window, specify the file location for the records you want 
to import: 

 
Under File Location, in the File Path box, type the full path (drive letter, folder, and 
file name) for an import file on a local hard drive or network drive, or click Browse to 
navigate to the location. 
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 Action 

5 Select one of the following files to which to import records: 
 Import to Online Save File 

You must be logged on. If you are not logged on, when you start the import 
process (step 7), the client opens the Logon OCLC Connexion window so that 
you can log on. 

 
Or 

 
 Import to Local Save File (logon not required) 

The client displays the full path and file name of your default local bibliographic 
and authority save files. 
— To change the default or create a new default file: 

- Click Local File Manager to open the Local File Manager window. (See 
Basics, Manage Local Files, “Manage local files for offline/online cataloging” 
for more information.) 

— If you import to a local file while offline, the client supplies your holding library 
code, institution symbol, and/or MARC organization code from the offline 
cataloging options you set in Tools > Options > General tab. 

6 Optional. 
 To apply default constant data or assign My Status, click Options. 
 To select a record standard and/or character set, click Record Characteristics. 

(See procedures below.) 

7 Click OK to import the records. 
Or 
Click Cancel to close the window without importing records. 

 
See detailed results in the following section. See details on import conversion to 
OCLC-MARC in the second section below. 

8 A message opens to let you select whether to delete the original file from which you 
imported. Click Yes to delete the file or No to keep it. 

 

Results of importing 
records 

 A temporary Import Results report opens automatically (you do not have to set 
an option as you do to get a temporary report for immediate export). The report 
for importing shows: 
— The path and file name of the import source 
— Report start time 
— Record standard for bibliographic records and character set for bibliographic 

and authority records selected for import (MARC-21 is the only available 
record standard for importing authority records) 

— Number of bibliographic and authority records successfully imported 

Caution: If you want to keep data in the Import Results report, you must print or 
copy and paste data into another application before you close the report. The 
client does not save the report. 

 If you import to the online save file and you are not logged on, the client opens 
the Logon OCLC Connexion window. After you log on, the client immediately 
imports the records. 

 The client imports all records in the file, beginning with the first record. 
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 If you import to the online save file, the client adds the bibliographic records to the 
bibliographic save file. 

 Imported bibliographic records are assigned the source status Imported. 

 Non-OCLC records are imported as OCLC workforms. Instead of an OCLC 
number, NEW appears at the top of the record in the non-editable information 
area. 

 By default, records are imported in MARC 21 format using MARC-8 character 
sets unless you changed the record standard to Dublin Core (Qualified or Simple) 
or to MARC XML or you changed the character set option to UTF-8 Unicode. 
(See the procedure for changing these options below.) 

 
Note: The temporary Import Results report does not list any fields not mapped 
when you import from one record standard to another. If fields do not map 
correctly or if there is a problem with the file (such as incorrectly formed XML), 
import fails. 

 If you selected the options, the system applies your default constant data and/or 
inserts My Status identifier. 
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Import conversion 
details 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Select a record 
standard and 
character set for 
imported 
bibliographic records 

The client does the following conversions, depending on whether the record is a 
WorldCat record (has an OCLC control number) or a workform (new record): 

 
OCLC record (has OCLC control 
number) 

 
Non-OCLC record (workform) 

 Workflow status is defined as In 
process. 

 Source status is defined as 
Imported 

 OCLC control number is retained in 
001 

 If the Lang element of the fixed field 
(008/35-37) is 3 blank spaces, blank 
spaces are converted to zxx (no 
linguistic content) 

 If record contains field 533 subfield 
7, data is converted to a 539 field 

 Fields 994 and 003 are deleted 

 Converted to workform 
 Workflow status is defined as New 
 Source status is defined as Imported 
 NEW is added in 001 
 Entered date (in 008/0-5) is replaced 

with current date 
 RecStat value (Leader/5) is set to n 
 Data in 040 and 049 is retained, if 

present; if not, default institution 
symbol is inserted in field 040 and 
holding library code is replaced with 
the default in field 049 

 
Note: If you are online, the client 
supplies the institution symbol and 
holding library code from your logon 
authorization. If you are offline, the 
symbol and code are supplied from 
options in Tools > Options > 
General. 

 
 If the Lang element of the fixed field 

is 3 blank spaces, blank spaces are 
converted to zxx (no linguistic 
content) 

 If record contains field 533 subfield 7, 
the data is converted to a 539 field 

 Fields 994 and 003 are deleted 

Note: If non-MARC-8 scripts are imported in MARC-8 data format, the non-MARC-8 
characters are saved in Numeric Character Reference (NCR) format. 

 
 Record standard. Select MARC 21, Dublin Core (Simple or Qualified), or MARC 

XML for importing records. 
 

Notes: 
— See details of importing from Dublin Core to MARC 21 below. 
— For more on Dublin Core standards, see a brief description in "Export 

bibliographic records" and details on the official Dublin Core Web site at 
www.dublincore.org. 

 Character set. Select the MARC-8 or UTF-8 Unicode character set to use in 
imported records. 

 
Note: If you select a Dublin Core standard or MARC XML, the client automatically 
selects UTF-8 Unicode character set. 

http://www.dublincore.org/
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 Action 

1 In the Import Records window (File > Import Records), before importing 
records, click Record Characteristics. 

2 Under Bibliographic Records, Record Standard, select one of the following 
record standards: 
 MARC 21 (default) 
 Dublin Core Qualified 
 Dublin Core Simple 
 MARCXML 
Notes: 
 Dublin Core standards are structured in XML. 
 See details of importing Dublin Core records to MARC 21 below. 

3 Under Bibliographic Records, Character Set, select one of the following: 
 MARC-8 (default) 
 UTF-8 Unicode 
Notes: 
 If you select a Dublin Core standard or MARC XML, the client automatically 

selects the UTF-8 Unicode character set. 
 Follow the same procedure in this window to select a character set option 

for importing authority records. The only available record format for 
imported authority records is MARC 21. 

4 To reset the selection to the default settings, click Reset. 
5 Click OK or press <Enter> to save your settings, or click Cancel to cancel 

changes. You are returned to the Import Records window. 
 

Notes: 
 

 If non-MARC-8 scripts are exported in MARC-8 data format, the non-MARC-8 
characters are saved in Numeric Character Reference (NCR) format. 

 See documentation on Unicode on the Library of Congress Web site at http:// 
www.loc.gov/marc/specifications/speccharucs.html. 

 
Details of importing Dublin Core records in MARC 21 

 
When you import Dublin Core Simple or Dublin Core Qualified records into the client 
in MARC 21, the conversion process is approximate. 

 
 By default, the client supplies values for the Books format, since there is no 

equivalent field for Leader or 008 in Dublin Core. Some fixed field elements may 
display fill characters. Please check or edit for correct values. 

 The following is a list of default fixed field values supplied to a record converted to 
MARC 21: 

http://www.loc.gov/marc/specifications/speccharucs.html
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Fixed field 
element 

 
Value 

 
Notes 

RecStat n  

Type a  

BLvl m  

Ctrl blank  

ELvl 3  

Desc u  

DtSt fill character You must provide 
values for these. If 
dates are 
unavailable, enter n 
and uuuu,uuuu, 
respectively 

Dates 4 fill characters and 
4 blanks 

Ctry xx  

Ills 4 blanks  

Audn blank  

Form s The client assumes 
that the record you 
are importing 
describes an 
electronic resource. 
If not, change this 
value. 

Cont 4 blanks  

GPub blank  

Conf 0  

Fest 0  

Indx blank  

LitF 0  

Biog blank  

Lang 3-character language code (or 3 fill 
characters) 

MRec blank  

Source d  

 To change from the Books format to another format, select a format from the 
drop-down list at the upper left of the fixed field display. 

 
Caution: 
— You must display the fixed field to have access to the MARC format list: Click 

View > OCLC Fixed Field > Top [or Bottom]. 
— When you change the MARC format, some fixed field values may be lost. 

Please check or edit for correct values. 
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 The temporary Import Results report that displays after import is completed (see 
description below) does not list any fields not mapped when you import from from 
a Dublin Core standard to MARC 21. If fields do not map correctly or if there is a 
problem with the file (such as incorrectly formed XML), import fails. 

 

Apply default constant 
data or assign a free- 
text My Status to 
imported records 

 
 Action 

1 Click File > Import Records (or press <Alt><F><I>), and then click Options. 

2 Apply default constant data: 
 
In the Import Options window, under Apply Default Constant Data , click the 
Bibliographic check box to apply your default constant data to imported 
bibliographic records. 
Or 
Clear the check box to import records without applying constant data. 
Default: Check box cleared. Records are imported without applying constant 
data. 

 
Note: The name of your default bibliographic constant data record is 
displayed under the Bibliographic check box. 

 
Results of applying default bibliographic constant data: 
 If you import to the online save file, the client uses your default online 

constant data. If you import to the local save file, the client uses your default 
local constant data. The client shows the name of the appropriate default 
constant data below the check box. 

 If your default constant data is set to apply the fixed field or both fixed field 
and variable fields, the fixed field is applied as is, even when the format of 
the constant data record is different. You do not get a prompt to change the 
format when you import records, as you do when you apply constant data 
to a single record. 

 If you also have authority records in the import file, you can select the 
Authority check box to apply the default authority constant data record. 

3 Assign a My Status. In the Import Options window: 
1. Under My Status for Bibliographic Records, in the Type list, select an 

OCLC offline service if the records to be imported were supplied by the 
service. For other records, leave the Type list empty. 

2. In the Identifier box, type a My Status in free text. 
Example: 
You select BibNote from the Type list and enter your name; for example, B. 
Smith. 
My Status = BibNote B. Smith 

 
Note: My Status can be up to 40 characters of free text, including the name 
of the OCLC service, if selected. My Status is a feature to help you identify 
and retrieve records in the save file. (My Status is unavailable for authority 
records, whether imported to the online or local save file.) 

4 Click OK or press <Enter> to save your settings, or click Cancel to cancel 
changes. You are returned to the Import Records window. 
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Find imported 
bibliographic records 

You can find imported bibliographic records two ways: 
 

 Show online save file or default local file statuses and then retrieve records with 
the status Imported. 

 Search the online save file or the default local file. 
 

Retrieve imported records by showing save file statuses 
 

 Action 

1 On the Cataloging menu, click Show > By Online Save File Status, or press 
<Ctrl><O>. 
Or 
Click Show > By Local Save File Status, or press <Alt><C><H><L>. 

2 In the Status List window under Source Status, click the check box for Imported. 

3 Click Show Records. 

Retrieve imported records by searching the save file 
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 Action 

1 
On the Cataloging menu, click Search > Online Save File, or click , or press 
<Ctrl><F3>. 
Or 

Click Search > Local Save File, or click , or press <F3>. 

2 Search for imported records: 
 In the Search Online [or Local] Bibliographic Save File window, leave the Search 

for boxes and index lists empty. In the first status list select Source Status, and 
in the adjacent list of source statuses, select Imported. 

Or 
Search for My Status: 
 In the Search Online [or Local] Bibliographic Save File window in the Search for 

box, type the My Status you assigned when you imported the records. In the 
adjacent index list, click My Status. Then click OK, or press <Enter>. 
Tip: 
You can search for any whole word in the My Status. If you entered a record type 
as My Status or part of My Status, you can search for the type selected only, for 
any word or phrase you entered in free text, or for the complete My Status, 
depending on how much you want to limit the results. 
Example: 
To find records with the My Status BibNote B. Smith: 
— Type BibNote, or type B. Smith or type BibNote B. Smith 

 

 
 
 

Download records 
from an OCLC service 

See Save Bibliographic Records, "Use bibliographic save file search results" for 
more information. 

 
To download records from the Product Services Web: 

 
 Action 

1 Open your Web browser and in the Address box, enter http://psw.oclc.org/ 
and press <Enter>. 

2 Click Records and Reports. 

3 Click the service that supplies the records you want. 

4 Enter your authorization and password and click OK. 

5 Right-click the Download link next to the record file, and click Save Target 
As. 

6 Navigate to the folder where you want to save the file, and click Save. 

7 Import into the online save file or a local save file and process the records 
using the Connexion client. 

http://psw.oclc.org/
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Process unresolved 
batchload records 

What are unresolved batchload records? 
 

 Unresolved records are bibliographic records for which no match was found in 
WorldCat by the OCLC Batchload service. 

 These records fail to match for a variety of reasons, including legitimate 
differences in cataloging practice, data errors, or other problems. 

 OCLC posts files of unresolved batchload records on the Product Services Web. 

 Unresolved records have the following characteristics: 
— They have the word NEW instead of an OCLC control number. 
— The file of records remains on the Product Services Web for 90 days before 

being deleted automatically. 
— If the unresolved records are generated by group batchload projects, they have 

identifiers in the 951 field. 
 

How to process unresolved batchload records 
 

Follow these steps after downloading the file of unresolved batchload records, 
importing the records into the client online or local save file, and retrieving them: 

 
 Action 

1 Search WorldCat for each item to see if a record exists. 

2 If a record exists (individual institution project): Follow local practice to 
determine if you should use the record you found instead of the one from your 
project. If you use the record you found, edit it as needed. 

 
If a record exists (group project): Copy the library identifier from the 951 
field in the unresolved record and paste it into the WorldCat record you found. 

 
If no record exists: Edit the unresolved record, as needed.. 

3 Take a final action on the record (produce, update, save, export). 
 
Note: If the record was in the online save file, the client automatically deletes 
it from the save file after the action is complete. If the record was in a local file, 
the client retains it; you can delete it using Action > Delete Record (or 
<Ctrl><Alt><D>). 

See also: Quick Reference 
 

See also: Import Records into Connexion Quick Reference at: 
http://www.oclc.org/support/documentation/worldcat/cataloging/userguide/import/. 

http://www.oclc.org/support/documentation/worldcat/cataloging/userguide/import/
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4 Retrieve local system records using a Z39.50 connection 
 

About retrieving local 
system records 

 Retrieve bibliographic records created in your ILS (Integrated Library System) 
and import them into the Connexion client. 

 Define a use attribute for searching your ILS (default: use attribute 12 - [local] 
Record#). 

 A search can retrieve one record at a time. 

 A retrieved local record is imported into the client and displayed as a MARC 21- 
formatted workform. The word NEW displays in the upper left corner of the 
workform, where the assigned OCLC number will display when you add it to 
WorldCat. 

 Once imported into the client, work with the record just as you do with any 
imported record (see the Import Bibliographic Records guide or client Help for 
more information). 

 

Set up a connection to 
a host local system 

 Action 

1 Click Tools > Options (or press <Alt><T><O>). Then click Z39.50. 

2 Enter settings for your Z39.50 connection (see the list describing the settings 
immediately following). 

3 Click Local Record Use Attribute to define a use name and value and other 
structure, truncation, or relation attributes, if needed, for local file record searching 

 
Default: Use name: Local#; value: 12; other attributes: Unspecified. 

 
More information about Z39.50 attributes is available on the Z39.50 Maintenance 
Agency Web site: 
 See tables of specific values for attributes, including use attributes at http:// 

lcweb.loc.gov/z3950/agency/defns/bib1.html 
 See more on the Bib-1 attribute set at http://www.loc.gov/z3950/agency/bib1.html 

4 When finished, click Close, or press <Enter> to apply the settings and close the 
window. 
Or 
Click Apply to apply the settings without closing the window. 
Or 
Click Cancel to cancel changes. 

 

http://www.loc.gov/z3950/agency/bib1.html
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Z39.50 settings: 
 

Z39.50 setting Required/optional, or uses default / Description 

Description Optional. 
Use to describe the ILS or a database you set up. 

 
Example: MIT 

Host Name or IP Address Required. 
Enter the local system name or IP. 

 
Example: library.mit.edu 

Port Number Required. 
Enter the local system port number. 

 
Example: 9909 

Database Name Required. 
Not case-sensitive. 

 
Example: mit01pub 

Local Record Use Attribute Use attribute is required (but the client provides a 
default): 

 
Click Local Record Use Attribute to check or 
change the use attribute name and value for 
searching the local system. 

 
Default name: Local# 
Default value: 12 

 
Other attributes are optional. 

 
Select a Structure, Truncation, or Relation attribute 
value. 

 
Default for all: Unspecified 

User Name Optional. 
If you do not enter this setting in options, the client 
prompts you to enter it each time you connect (Tools 
> Z39.50 > Connect). Case sensitivity depends on 
your local system requirements. 

Password Optional. 
If you do not enter this setting in options, the client 
prompts you to enter it when you connect. You must 
enter a password when prompted, unless not 
required by your local system. Case sensitivity 
depends on your local system requirements. 

Preferred Message Size Default: 105000 bytes. The client uses the default 
unless you change it. 
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Z39.50 setting Required/optional, or uses default / Description 

Initialization Delay (seconds) Optional. 
Default: 0 seconds 

 
Enter the number of seconds you want the client to 
wait before initializing the connection, 
if you want a delay.. 

Maximum Record Size Default: 105000 bytes. The client uses the default 
unless you change it. 

Connection Retries Optional: 
Default: 0. 

 
Enter the number of times you want the client to try to 
connect, if you want to re-try automatically. 

Connection Idle Timeout 
(minutes) 

Optional: 
Default: 20 minutes. 

 
The client uses the default unless you change it. 
Range: 5 to 20 minutes. 

 
Note: The Z39.50 session terminates automatically if 
you do not perform searches within the interval 
specified in this setting. 

 

Note: If you connect to more than one host or more than one database, change the 
settings in the Z39.50 tab before connecting, or create another user profile, enter 
different settings in the Z39.50 tab in the new profile, and switch user profiles before 
connecting. 

 

Connect to a local 
system host and 
retrieve a record  Action 

1 Click Tools > Z39.50 > Connect (or press <Alt><T><Z><C>). 

2 If you did not enter a user name or password in Tools > Options > Z39.50, the 
client prompts you to enter them: 
1. In the Local System Password window, enter a user name and, if required by 

your local system, a password. 
2. Click OK to connect and open the Search Local System window, or click Cancel 

to cancel connecting. 
If you entered a user name and password in the Z39.50 options page, the client 
automatically supplies them, connects, and opens the Search Local System 
window. 
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 Action 

3 In the Search Local System window, in the Record ID Number box, type the 
search term/number for the use attribute you dinfined for retrieving local records. 
Or 
Click the arrow at the right of the box to display a list of up to ten terms you entered 
previously, and click to select one. 

 
Results: 
 If the search is successful, the client imports and displays the record as a 

workform in MARC format. 
 If the search fails, the client gives you a message. To try the search again, click 

Tools > Z39.50 > Search. 

4 Click Find to send the search, Cancel to cancel the search and keep the Z39.50 
connection open, or Cancel and Disconnect to cancel the search and terminate 
the Z39.50 session. 

5 Optional. To retrieve another local record: 
1. Pin the displayed record open (View > Pinned or <Shift><F4>) if you want to 

keep it open. If you do not, the next retrieved record replaces the first and you 
must do the search again to get the first record back. 

2. Click Tools > Z39.50 > Search (or press <Alt><T><Z><S>), and enter another 
search term or number. 

 
Work with a record retrieved from your local system the same way you work with 
other records imported in the client. 

 
For example, generate an authority record from a heading in the record, add the 
record to WorldCat, etc. 

6 When finished importing local records (one at a time), click Tools > Options > 
Z39.50 > Disconnect (or press <Alt><T><O><D>). 

 


	Revision History
	Table of Contents
	2 Export bibliographic records
	3 Import bibliographic records
	4 Retrieve local system records using a Z39.50 connection
	1 Create an export destination
	2 Export bibliographic records
	 Immediate export while logged on or offline.
	 Generated ISBN expansion.
	More about Dublin Core
	Results of character set selection:
	— Location

	3 Import bibliographic records
	Caution:
	Notes:
	Notes:
	Details of importing Dublin Core records in MARC 21
	Caution:
	View > OCLC Fixed Field > Top [or Bottom].
	Retrieve imported records by showing save file statuses
	What are unresolved batchload records?
	How to process unresolved batchload records
	See also: Quick Reference

	4 Retrieve local system records using a Z39.50 connection
	Z39.50 settings:


